Home Support Affiliate Linkalizer for Amazon Support Amazon Button Disappeared

This topic contains 4 replies, has 3 voices, and was last updated by  Subhamay Ray 3 years, 5 months ago.

  • Author
    Posts
  • #2969

    beng_trans
    Participant

    After the recent update, I am getting some text where the button should be. The text reads:

    Warning: Missing argument 3 for Affiliate_Linkalizer_Amazon_Public::create_link() in /home/bengalit/public_html/bookreviewbook.com/wp-content/plugins/affiliate-linkalizer-amazon/public/class-affiliate-linkalizer-amazon-public.php on line 80

    I don’t have much technical knowledge. So please help.Here’s the link to one of my pages:

    http://www.bookreviewbook.com/review-dickens-study-guide-by-lee-fisher-gray/

    #2971

    Donna
    Keymaster

    Hello,

    Our sincerest apologies for introducing this issue with the latest version of the Book Review plugin.

    While we work on a fix for the issue, you can revert to version 2.2.3 of Book Review. Please click here to download 2.2.3. You’ll need to unzip it and place it in the wp-content/plugins folder on your server, overwriting the existing book-review folder.

    Thank you for your patience while we work on the issue.

    #2973

    Subhamay Ray

    Thanks for your suggestion! It worked for me. I’ll wait for the new version of the plugin.

    #2975

    Donna
    Keymaster

    Version 2.3.1 of the Book Review plugin has just been released that fixes this issue. Please do let us know if you continue to encounter problems after the upgrade.

    Just a note that when I visited your site earlier, I noticed that the error message was being displayed directly on the page. I suspect that you may have the debugging parameters turned on in your wp-config.php file. You may want to consider turning them off so that visitors to your site don’t see any unsightly error messages. In particular, the following properties are normally set to false in wp-config.php for a live site:

    define( 'WP_DEBUG', false );
    define( 'WP_DEBUG_LOG', false );
    define( 'WP_DEBUG_DISPLAY', false );

    Once again, thanks for taking the time to report the original problem!

    #2980

    Subhamay Ray

    Hello,

    This time the upgrade worked perfectly. Many thanks for your additional note. I’ll turn those debugging parameters off.

    Thanks again for your help. Wish you a Very Happy and Prosperous New Year!

    Regards,

    Subhamay Ray

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Amazon Button Disappeared’ is closed to new replies.